Připojení k TTC

postup pro připojení klientského MikroTiku. potřeba vědět:

  • uživatelské jméno
  • heslo
  • certifikát
  • passphrase certifikátu
  • vlastní subnet

Certifikát

  • Přihlásit se přes SSH na ovpn.mysh.cz
  • cd /etc/openvpn/ca/
    source vars
    ./build-key <lokalita>.client.vpn.mysh.cz
  • výsledné certifikáty jsou v keys/

Na serverovém

/ppp profile add name="ovpn-gutova" local-address=172.17.5.108 remote-address=172.17.5.208
/ppp secret add name="ovpn-gutova" service=ovpn profile="ovpn-gutova" password="Goru8248Quri9583Boeo8639Faru6432"

Na klientovi

  1. nahrát certifikát přes ftp do mikrotiku
  2. importovat certifikát, s tím, že při importu se zeptá na passphrase
        /certificate import file=ovpn-cernosice.pem
  3. přejmenování certifikátu
        /certificate set cert1 name="ovpn-cernosice"
  4. naimportování privátního klíče, opět se zeptá na passphrase
        /certificate import file=ovpn-cernosice.p12
  5. přidat PPP profil, kterým se připojit
      /ppp profile add name="ovpn-client"
  6. vygenerovat si MAC adresu (např. vendor VMware) na http://justynshull.com/macgen/macgen.php
  7. vytvořit OpenVPN spojení
      /interface ovpn-client \
        add name="ovpn-ttc" connect-to="vpn.mysh.cz" \
        port=1194 mode=ethernet user="<uzivatel>" \
        password="<heslo>" profile="ovpn-client" \
        certificate="ovpn-cernosice" cipher=aes256 \
        mac-address=<vygenerovaná-mac> add-default-route=no
  8. povolit RIP protokol pro svou síť
      /routing rip network add network="172.17.0.0/21" comment="Recieve routes from VPN"
      /routing rip network add network="<vlastni-subnet>/24" comment="Send this network to VPN"

MAC adresy

Pro vytvořený tunel je nutné říct nějakou MAC adresu, pod kterou na síti bude vystupovat, tady je několik předgenerovaných

MAC použití
00:0C:29:55:A6:4D –volná–
00:0C:29:FF:6A:3D –volná–
00:0C:29:45:8D:4A –volná–
00:0C:29:E2:06:3A –volná–
00:0C:29:BC:D7:F4 –volná–

Certifikáty

mikrotik/postup-pripojeni-k-ttc.txt · Poslední úprava: 26.12.2017 14:33 autor: vm

Nástroje pro stránku